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1  Introduction to Maple

Chapter 1: Introduction to MapleMaple is an analytic computation system. It performs mathematical 
computations and manipulations for solving problems from various technical 
disciplines. Most significantly, Maple computes both numerical as well as 
symbolic solutions to mathematical expressions. This means that Maple 
performs computations on expressions that contain symbols, such as π or x, 
without performing numerical approximations. For example, Maple 
determines that the derivative of ������ is ������, even when � has not been 
assigned a value. Maple provides exact solutions to many technical problems. 
In addition, Maple has visualization tools that contribute to the problem-
solving process. 

1.1 Installing Maple
For installation and licensing instructions, refer to the 	��
���
�
� file on 
your Maple CD.

1.2 Starting Maple
You can run the Maple program with either a graphical user interface or a 
command-line interface. In the graphical user interface, you can enter Maple 
commands at the prompt, or you can use palettes, context-sensitive menus, 
and other features to construct commands. The worksheet is your Maple 
document, and in it you can format and document your commands. 

In the command-line interface, you enter Maple commands at the prompt. 
While you cannot access the graphical interface features, the command-line 
1



2 • Chapter 1: Introduction to Maple
interface uses less memory than the worksheet interface. It is therefore useful 
in solving very large or complex problems on computers with limited memory.

This guide covers the standard interface. For more information on the 
command-line interface, look in your Maple folder for the �������

�
�file 
(for Macintosh, refer to the ������������������� file).

To start the standard interface in Windows:

• From the Start menu, choose Programs, Maple 8, then Maple 8.

To start the standard interface on a Macintosh computer:

1. Double-click the Maple 8 application icon on the Macintosh hard drive.
2. If prompted, enter your User ID in the Maple 8 Multiple User Logon 

dialog box, and click Log On. If you have entered a new ID, you have to 
confirm its creation.

To start the standard interface in UNIX or Linux:

• Enter the full path, for example,
��������������������������� 

Or,

1. Add your Maple 8 directory (for example, ��������������������) to your 
command search path.

2. Enter ������.

On all operating systems, the first Maple worksheet session opens with the 
Introduction to Maple 8 page that points you to the New User’s Tour, updates, 
and other introductory help pages. Subsequent worksheet sessions start with 
a new, blank worksheet.

1.3 The Maple Window
The Maple window resembles that of a typical application program. The main 
features are shown in Figure 1-A on page 3. 
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Figure 1-A Maple window features

A Toolbar
A toolbar containing shortcut buttons.

B Context bar
A toolbar containing context-sensitive shortcut buttons. (This means that the 
buttons change based on the cursor location or selection.) It can also contain a 
field for editing and entering text.

C Section heading
The name or title of a section.

D Maple input
A mathematical expression that Maple evaluates. By default, input commands 
are entered at the prompt, “>”, and are displayed in red type. The resulting 
output is displayed beneath.
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1.4 Accessing Help Pages
The commands and features in Maple are documented in online help pages. To 
view help pages, at the prompt, enter a question mark (�) followed by the 
name of the command or subject on which you want help. Do not enter any 
spaces. For example, to refer to the help page on natural logarithms, enter 
���. For information on different ways to get help, see The Help System on 
page 25.

E Maple output
The result of an executed Maple input command. By default, Maple output is 
displayed in blue type in Standard Math Notation.

F Execution group
A set of Maple input with its corresponding output.

G Worksheet
A Maple document.

H Section
A grouping of worksheet elements.

I Section range bracket
A line that “brackets” the elements of a section.

J Prompt
By default, the Maple prompt is a greater-than symbol that indicates where to 
enter Maple input.

K Symbol palette
A collection of buttons for entering mathematical symbols in Maple.

L Expression palette
A collection of templates for entering mathematical expressions in Maple.

M Matrix palette
A collection of templates for entering matrices in Maple.

N Vector palette
A collection of buttons for entering vectors in Maple.
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1.5 Entering Expressions in Maple
To enter expressions at the prompt, use the keyboard, the palettes, or both. 
Using the keyboard is the most direct method, but the palettes enable you to 
enter a command without knowing its syntax.

There are two types of input display. Use Maple Notation to display input as 
Maple syntax. Maple Notation is the default. Use Standard Math Notation 
to display input in typeset notation as it appears in a textbook.

These examples step you through entering  in various ways.

To enter the integral in Standard Math Notation by using the palettes:

1. Display the palettes, if necessary. From the View menu, choose Palettes, 
then Show All Palettes. The Symbol, Expression, Matrix, and Vector 
palettes are displayed. Move the palettes to the side of the worksheet, if 
necessary.

2. If required, change the input to Standard Math Notation. (If there is a 
question mark (?) after the prompt, the input is already set to Standard 
Math Notation.) At the prompt, right-click. The context-sensitive menu is 
displayed. Choose Standard Math.

3. On the Expression palette, click . The integral symbol appears, and 

the question mark placeholder is selected.

4. On the Expression palette, click . The function sin appears, with 
another placeholder. 

5. Enter � (on the keyboard), and press TAB to go to the next placeholder.
6. Repeat step 5.
7. Enter � (zero), and press TAB.

8. On the Symbol palette, click . (It is in the bottom row.)

9. Press ENTER. 

Your worksheet should resemble that of Figure 1-B on page 6. 

x( )sin xd
0

π

∫
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Figure 1-B Integral input in Standard Math Notation

The next example shows you how you can use the palettes to enter the 
expression and learn the Maple command syntax at the same time.

To enter the integral in Maple Notation by using the palettes:

1. On the Expression palette, click . The integral command appears, 

and the %? placeholder is selected.

2. On the Expression palette, click . The function sin appears, with 

another placeholder. 
3. Enter � (on the keyboard), and press TAB to go to the next placeholder.
4. Repeat step 5.
5. Enter � (zero), and press TAB.

6. On the Symbol palette, click . (It is in the bottom row.)

7. Press ENTER. 

Note: Maple appends a semicolon to the end of the command. This signifies the 
end of the statement.



1.5  Entering Expressions in Maple • 7
Your worksheet should look similar to the one in Figure 1-C.

Figure 1-C Integral input in Maple Notation

Now that you know the correct notation, you could enter the expression at the 
prompt. For more information on entering expressions, see the examples in 
the next chapter and refer to ���������
���������������
����  (Enter 
Expressions in Maple). For more information on using palettes, refer to 
���������
�����������������

�� (Overview of Palettes).

For the rest of this guide, it is assumed that you are entering expressions in 
Maple Notation.
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2  Solving a Problem

Chapter 2: Solving a ProblemThis chapter presents a mathematical problem with its solution. The 
discussion of the problem and its solution introduces you to key features of the 
Maple program. Do not worry too much about the mathematics. The purpose 
of this problem is to show you Maple; the mathematics is secondary.

Note: When entering Maple commands, please keep in mind that they are case-
sensitive.

2.1 Scenario
A skier has made her way to the top of a mountain. She wants to take the 
steepest path down, which she can find by performing the calculations 
outlined in this chapter. Start by opening a new worksheet for this problem.

To open a new worksheet:

• From the File menu, choose New.

2.2 Commands in Packages
Some of the commands used in the discussion are found in packages. A 
package is a group of routines related to a particular area of mathematics. You 
can always access commands in packages by using the long form, that is, 
specifying both package and function name: ����� �!"���
���#�

�, but to 
be able to use the short form, that is, specify only the function name, use the 
��
� command first.
9
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To access commands in the ����� package:

• At the prompt, enter the following and press ENTER.
��
�����
��$

After executing the command, Maple lists any warnings, followed by all of the 
commands that are included in the package. For the ���
� package, a 
warning indicates that the name of one of the commands in the package, 
���� ���������is the same as a global name that is already defined. After 
executing the ��
� command, the original meaning of the command is not 
available until you restart Maple. 

For other methods of accessing commands in packages, refer to Section 3.7, 
“The Organization of Maple,” in the Maple Learning Guide. For a list of all the 
packages in Maple, refer to ������������ �� (Index of descriptions for 
packages of library functions).

2.3 Math and Visualization
Use some mathematical and visualization commands to determine basic 
properties of the hill. If you want more information on any of the commands 
used here, enter a question mark, followed by the name of the command. For 
example, to find help on the exponential command, enter ���� (The 
Expontential Function).

Suppose that the height at a point ���%� of the hill is given by ", in thousands 
of feet.

To enter the expression in Maple:

• At the prompt, enter the following and press ENTER:
"�&'�(��)*�+,*%+,���)�-*)�,.��*)�+,*)�,.�%*,�+,�$

The expression for the shape of the hill is assigned to the name " by means of 
the assignment operator “:=” so that it can be referred to in subsequent 
calculations. For more information about assignments, refer to �&' (The 

f 3

1 x2 y2+ +( ) 1
4
--- x 1+( )2

2
------------------- y 2+( )2

2
-------------------+ + 

 
---------------------------------------------------------------------------------------------=
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assignment statement), and for more information about names, refer to ������ 
(Names).

Plotting the hill
Before solving the problem, it would be helpful to get an idea of what the hill 
looks like (and an idea of what the answer should be). 

To plot the expression:

1. Right-click the output of the expression (for Macintosh, option-click). The 
context-sensitive menu is displayed.

2. Choose Plots, 3-D Plot, then x,y. Maple inserts the plot into the 
worksheet.

Note: The content of context-sensitive menus varies depending on the cursor 
location or selected expression. For more information, refer to 
���������
���������������������
���� (Use Context-Sensitive Menus 
to Manipulate Expressions).

To add axes:

• Right-click the plot (for Macintosh, option-click), choose Axes, then 
Boxed.

To modify the axes ranges:

1. Right-click the plot (for Macintosh, option-click), choose Axes, then 
Ranges.

2. In the Axis Range dialog box:
a.Under X Axis, click the button beside the top range box. Enter −- in 

the top box, then enter ( in the bottom box.
b.Similarly, change the Y Axis to range from −- to (.
c.Click OK.

The visualization tools in Maple enable you to see the surface from more than 
one angle.

To rotate the surface:

1. Click the plot to select it.
2. Place the pointer on the plot, but not directly on the surface of the hill.
3. Drag the plot in any direction. The surface rotates.
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Depending on how you rotated the plot, it may look similar to Figure 2-A.

Figure 2-A Plot of the hill

While you could look at the surface and guess what the highest point is, you 
can obtain a more precise answer by using calculus.

Finding the maximum point of the surface
Determine the location of the top of the hill by taking partial derivatives, 
setting them to �, and solving for � and %.

To find the partial derivative of � with respect to �:

• At the prompt, enter the following and press ENTER. 
"��&'���""�"���$
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To find the partial derivative of � with respect to �:

• At the prompt, enter the following and press ENTER.
"%�&'���""�"�%�$

Since you are interested in the real solution, use the "���/� command instead 
of the more general ���/� command.

To solve the system of equations 	��
��
��
��:

• At the prompt, enter the following and press ENTER.

��0�%�&'�"���/��1"�'��"%'�2�1��%2�1�'3(

��%'3(

�2�$

The top of the hill is therefore at approximately 1��'�−
4�,5)��)44�
%�'�3)
6�7,,��-�2.

Note: Sets do not preserve order, so you may instead obtain the equivalent set: 
{ %�'�−)
6�7,,��-�����' −
4�,5)��)442.

Finding the skier’s starting point
Assume that the skier does not start at the peak but slightly to the side. To 
approximate this location, add a small factor, say �
�7, to the �3 and %3
values. Assign these values to the variables � and % and then add the 
approximating factor.

To assign the values to the variables:

• At the prompt, enter the following and press ENTER.
���� ��8�$

The ditto operator (%) refers to the result of the previous computation. For 
more information, refer to �8 (The ditto operators).

To define the starting �3 and %3values, �)�and�%),�respectively:

• At the prompt, enter the following and press ENTER.
�)&'�*�
�7$
%)&'%*�
�7$

The names � and % have values assigned to them. Since � and %�are used as 
variables in future calculations, they must be unassigned before proceeding.

To unassign � and %:

• At the prompt, enter the following and press ENTER.
�&'9�9$
%&'9%9$
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To find the �-coordinate of the starting point:

• Evaluate the function representing the hill at the �3 and %3values 
representing the starting point (�)�%)). At the prompt, enter the following 
and press ENTER.
:)&'�/���"�1�'�)�%'%)2�$

The numerical result {�)�'3
67,5)��)44���%)�'�3)
;77,,��-���:)�'�
,
)-75()-7(2 is an approximation of the skier’s starting point.

Finding the path down
Before you find the path, take a look at the level curves of the hill to get an 
idea of the skier’s path.

To plot the level curves:

• The ���
������
 command with five contours suggests an interesting 
shape, as shown in Figure 2-B. At the prompt, enter the following 
command and press ENTER.
���
������
�"���'−,

)��%'−(

)�����
����'7��"�����'
����$

Figure 2-B Level curves of the hill 
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2.4 Using a For Loop—Finding the Path
Next, construct and plot the path on the surface of the hill that the skier 
should take. The negative of the gradient (−∇ "���%�����− ����"���%�) in the 
Maple language), gives the � and %�components of the direction of steepest 
descent. At each point ���%�:� on the surface, the skier should travel in the 
direction of −∇ "���%�, while staying on the surface. Since −∇ "���%� changes 
from point to point, you can break the process into steps, building an 
approximation of the path of steepest descent. If the step size is too large, the 
path may leave the surface of the hill. If the step size is too small, you derive 
no benefit from the increased number of calculations.

Performing the initialization
Assume that the skier is currently at the starting point (�)�%)�:)). Use a 
timestep of 0.1 and find 25 points along the path. Use the arrays ����
(� and 
���
�(� to store the values of the computed points and the direction taken, 
respectively. To simplify the calculation of the points and route, define vector 
representations of the expressions for the hill and the derivatives with respect 
to both � and %.

To define vector representations of the expressions:

• At the prompt, enter the following and press ENTER.
 &'�/���"�1�'<!)#�%'<!,#2�$
 �&'�/���"��1�'<!)#�%'<!,#2�$
 %&'�/���"%�1�'<!)#�%'<!,#2�$

To declare the arrays for storing the values at each timestep:

• At the prompt, enter the following and press ENTER.
����
(�&'=���%�)

,7�$
���
�(�&'=���%�)

,7�$

To define the initialization:

• At the prompt, enter the following and press ENTER.

����
��&'�
)$
����
(�!)#&'>�)�%)�:)?$

Note: The notation >�)�%)�:)? defines a Vector while P[i] accesses the ith 
element of the list P. For more information about Vectors, refer to �@��
�� 
(Vector - construct a Vector). For more information about lists, refer to ����
� 
(Sets and Lists).
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Specifying the For Loop
To obtain the additional 24 points, use a "�� loop. A "�� loop repeatedly 
executes a sequence of Maple commands entered between the "�� and ����
commands of the loop, that is, in the loop body. It executes the commands as 
the value of a numeric variable, called an index, varies from its specified 
initial value to its specified final value. The value of the index is incremented 
after each execution of the commands in the body of the loop. The iteration 
stops when the value of the index is greater than the specified final value. For 
information on other programming structures in Maple, refer to the Maple 
Introductory Programming Guide.

To start the ��� loop:

• At the prompt, enter the following and press ENTER.
"�����"����)�
��,-���

Note: After you press ENTER, Maple returns the message: “Warning, premature 
end of input.” It is simply reminding you that the "�� statement is not complete. To 
continue entering your input without receiving this warning, use SHIFT+ENTER to 
go to the next line.

The next commands comprise the body of the "�� loop. These commands find 
the skier’s position at the end of each time step.

To construct the 3-D normalized negative of the gradient vectors:

• At the prompt, enter the following and press ENTER.
���
�(�!�#�&'�������=� ����!A������:�#��/���>3 ��3 %��?��
<'����
(�!�#��$

To find the next point in the skier’s path:

• At the prompt, enter the following and press ENTER.
����
(�!�*)#�&'�
�/���><!)#�<!,#� ?�<'����
(�!�#*
����
��.���
�(�!�#�$

To complete the ��� loop:

• At the prompt, enter the following and press ENTER. Remember to end the 
line with a colon to suppress the output.
������&

This command ends the "�� loop. After you press ENTER, the five commands in 
the loop body are repeated 24 times. At the end of each iteration, the value of � 
is increased by 1. That is, for the first iteration, the value of � is its initial 
value 1, for the second 2, and so on. For the last iteration the value of � is 24. 
Maple exits at the end of the 24th iteration once � is set to 25 (since 25 is 
outside of the bounds of the loop).
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To graph the path, you must convert the points representing the path of the 
skier, which are stored in the ����
(� array, to a list.

To convert the ������� array to a list:

• At the prompt, enter the following and press ENTER.
���
����
�(��&'�!��B�����/��
������
(�!�#�����
�����')

,7��#& 

You will use these lists in the next section.

2.5 Visualization Revisited
The visualization tools in Maple enable you to create different kinds of two- 
and three-dimensional plots in a number of coordinate systems. In addition, 
you can plot more than one element on a single set of axes. First assign the 
individual plots to names, then plot them together by using the ������% 
command.

To plot the hill and assign it to the name ��������:

• At the prompt, enter the following and press ENTER. Remember to end the 
line with a colon to suppress the output.
����
����&'����
(��"���'−(

(��%'−-

-������'������&

To plot the set of points on the path as a straight line and assign it to 
������:

• At the prompt, enter the following and press ENTER.
��
�(��&'�����
���
(�����
����
�(����
%��'�����������'����&

To plot the starting point of the skier and assign it to �����:

• At the prompt, enter the following and press ENTER.
������&'�����
���
(�����/��
�����
(�!)#����
����%����'�������
�%������:�'7�������'%������& 

To view all three elements at once: 

• At the prompt, enter the following and press ENTER.
������%�����
��������������
�(��$

To rotate the surface of the plot to see the path:

1. Click the plot to select it.
2. Place the pointer on the plot, but not directly on the surface of the hill.
3. Drag the plot in any direction. The surface rotates.
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Your plot should look similar to that of Figure 2-C. For a list of all the 
different types of plots, refer to ����
��(Introduction to the plots package). For 
overview information on plots, refer to ���������
����
��
��"��� (Overview 
of Plotting). For information on different plot options, refer to ����
���
�����
(plot[options]) and ����
(����
��� (plot3d[option]).

Figure 2-C The skier’s starting position, the path, and the hill

Similarly, you could display a contour plot with the skier’s path.
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2.6 Documenting Your Work
You can document the steps you took to solve a problem by adding some text 
to your worksheet. You can then format the text by using different predefined 
styles, or you can define your own styles. In addition, you can insert formatted 
mathematics in your text.

Adding text
Add a title to your worksheet, and add some text to describe the problem that 
you are solving. You can also add text in other locations in the worksheet to 
describe how you are solving the problem. 

To add a title to your worksheet:

1. Insert a new execution group at the top of the worksheet: place the 
insertion point on the top line, and from the Insert menu, choose 
Execution Group, then Before Cursor. 

2. Click  to add text rather than a Maple command.

3. Enter the following text.
C���D����9��<�
�

4. From the style box (indicated in Figure 2-D), select Title.
5. Press ENTER, and enter your name. It is automatically formatted in the 

Author style. 

Figure 2-D Worksheet with a title; context bar for text

Style box
Choose styles for the text in your 
worksheet.

Text insert button
Insert text in your worksheet.
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It is possible to redefine the styles (their alignment, font, underlining, and so 
on). For more information, refer to ���������
��������
�� ��
%��� 
(Overview of Maple Text Styles).

To add a text description to the worksheet:

1. Place the insertion point on the first input command (the ��
� command).
2. From the Insert menu, choose Execution Group, then Before Cursor. 

A new prompt appears.

3. Click  to add text.

4. Enter the following sentences:
=����������������������%�
��
���
����"�������
���
�D������
��
��

����
����
�����
���
����������������������"�����%����"����� �

����������
�������
���������
������������



To add formatted math to the text:

1. To add another paragraph and an extra space to the worksheet, press 
ENTER twice. 

2. Enter the following text.
D�������
��
�
������ �
��
�������
����%���"�
����������� �/����%�
"'(��)*�+,*%+,���)�-*)�,.��*)�+,*)�,.�%*,�+,������
����������"�
"��



3. Highlight the equation. 
4. From the Format menu, choose Convert to, then Standard Math. The 

equation appears in standard math notation.
Your worksheet should look like that in Figure 2-E on page 21.
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Figure 2-E Text description with formatted math

Structuring the worksheet with sections
You can add sections to your worksheet to group various elements. When you 
enclose elements in a section (or indent them), Maple automatically inserts a 
place for a section title. 

To add and title a section:

1. Select the first two paragraphs in the worksheet. (They begin with “A 
skier …” and end with “… in thousands of feet.”)

2. Click  (Indent) on the toolbar. A large range bracket topped by a little 
square appears to the left of the two paragraphs you selected.

3. Click next to the  box, and enter the title of the section:
<�������E������
���

Compare your worksheet to Figure 2-F on page 22. You can continue to 
document each step in the problem. For more information about sections, refer 
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to ���������
��������
�� ��
���
���� , (Structure Worksheets With 
Sections).

Figure 2-F Worksheet with a titled section

Adding numbers
If you plan to print your worksheet, you may find it useful to add page 
numbers to the bottom of the page.

To add page numbers (centered at the bottom of the page):

1. From the Format menu, choose Page Numbers.
2. In the Page Number dialog box: 

a.Select the Show Page Numbers check box.
b.Under Vertical location, leave the default selection at Bottom.
c.Under Horizontal location, click Center.
d.Click OK.

For more information about the page number options, refer to 
���������
��������
�� ��� ���������(Page Numbers).
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To save your worksheet:

• From the File menu, choose Save. If you have not saved it previously, you 
are prompted for a file location and name that ends with .mws (for Maple 
worksheet).

2.7 Exporting to HTML
You can export your worksheet as an HTML file. (Maple worksheets can also 
be exported to HTML with MathML, LaTeX, Maple text, plain text, Rich Text 
Format (RTF), and Extensible Markup Language (XML). For more 
information, refer to ���������
����� �� ������
 (Export a Worksheet).)

To export a worksheet as HTML:

1. With the worksheet you want to export open, from the File menu, select 
Export As, then HTML.

2. In the Save As dialog box, enter the name of the file, and click Save.
3. In the HTML Options dialog box, enter the name of the folder for the 

images (plots and formatted math) in your worksheet.
4. The resulting HTML page will include the worksheet filename and all of 

its sections as links. If you want these links to appear in a left frame, 
select the Use Frames check box. If you prefer that the links be at the top 
of the page, separated by a horizontal rule, clear the Use Frames check 
box.

5. Click OK.

The HTML file is created. You can then open it in your Web browser.

For more information on how to export worksheets, refer to ���������
�
���� �� ������
FCG� (Export as HTML). For information on how Maple 
translates the worksheet to HTML, refer to 
���������
����� �� ������

�FCG� (Translation of Maple Worksheets to 
HTML).
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3  Getting More Information

Chapter 3: Getting More InformationThis guide is a brief introduction to the Maple program. Maple has many 
other features, such as spreadsheets, an Excel link, and a MATLAB link. To 
learn more, you can use the Maple help system, read the Maple 8 manuals, 
and access other online resources.

3.1 The Help System
Maple provides a custom online help system consisting of over 3000 reference 
pages. The help system is a convenient resource for determining the syntax of 
Maple commands and for learning about the features of the Maple program.

Maple help pages
When you invoke a particular help page in Maple, it is displayed in a new 
window, with the Help Browser at the top. Most help pages in Maple are 
command reference pages, such as the one in Figure 3-A on page 26.
25
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Figure 3-A Sample Help page

Help page toolbar
The help page toolbar provides commands that make it easier for you to use 
the help system. Some of the commands are shown in Figure 3-B on page 27.

Help page name
Full name of the help page. Help Browser

Tool for perusing 
help file topics. Click 
on a topic to display 
either its subtopics or 
its help page. A topic 
has subtopics if the 
topic name is 
followed by an 
ellipsis (…).

Name and 
description
Statement of the name 
and a brief description 
of the Maple 
command.

Examples
Sample Maple 
commands. To copy 
all the examples on a 
help page, from the 
Edit menu, choose 
Copy Examples. You 
can then paste these 
examples into a Maple 
worksheet and 
execute them.

See Also
Section that contains 
hyperlinks to related 
topics.
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Figure 3-B Help toolbar

Getting help
Maple provides many ways of accessing the information in the help system.

• The help command displays the help page of a specified command or topic.
• The Help Browser lists the help pages in a hierarchy organized by topic. 
• Topic search finds a help page that matches a specific topic name.
• Full text search finds help pages that contain a particular word or phrase.

Help command    If you know, or can guess, the name of a help page, you can 
access it by using the help command. It is the most direct method of obtaining 
help. To use the help command, at the prompt, enter a question mark followed 
by the command or topic on which you want help and press ENTER. Note that 
you do not have to terminate a help command with either a semicolon or a 
colon. For more information, refer to ����� (help).

Help Browser    The Help Browser is a five-column table of contents that lists 
the help pages by topic. Some topics are listed in more than one location, to 
help you more easily find the information you need. For more information, 
refer to ���������
���"������������� (Use the Help Browser).

Topic search    Topic Search finds the help page that has the specified topic 
name (for example, “ithprime”). It may find a help page that lists the specified 
topic name as a synonym or an alternate spelling instead. Note that Topic 
Search is not case-sensitive. To use Topic Search, from the Help menu, choose 
Topic Search. Enter your Topic word and click Search. For more 
information, refer to ���������
������
���������� (Perform a Topic 
Search).

Back
Display the previously 
viewed help page.

Forward
Display the subsequently 
viewed help page.

Alpha forward
Display the help page that is next 
alphabetically in the help system 
hierarchy. 

Alpha back
Display the help page that is 
previous alphabetically in the 
help system hierarchy. 

Parent
Display the parent help 
page.

Introduction
Display the Introduction to 
Maple 8 page.
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Full text search    Full Text Search searches all the help pages and returns 
results based on the frequency with which the text occurs. With this search, 
you can search on more than one word. However, the results may include 
pages that contain only one of the words listed in the Topic box, and not all of 
them. Note that Full Text Search is not case-sensitive. To use Full Text 
Search, from the Help menu, choose Full Text Search. Enter your word or 
words, and click Search. For more information, refer to 
���������
������"���
��
������ (Perform a Full Text Search).

3.2 Manual Set
The Maple software comes with the following manuals.

Title Content

Maple 8 Getting Started 
Guide

This guide contains an introduction to the 
graphical user interface and a tutorial that 
outlines using Maple to solve mathematical 
problems and create technical documents. In it, 
there is additional information for new users about 
the online help system, New User’s Tour, example 
worksheets, and Waterloo Maple Inc. Web site.

Maple 8 Learning Guide This guide explains how Maple and the Maple 
language work. It describes the most important 
commands and uses them to solve technical 
problems.User hints for Maplets are also described 
in this guide.

Maple 8 Introductory 
Programming Guide1

1. The Student Edition does not include the Maple 8 Introductory Programming Guide 
and the Maple 8 Advanced Programming Guide. These programming guides can be 
purchased from school and specialty bookstores or directly from Waterloo Maple Inc.

This guide introduces the basic Maple 
programming concepts, such as expressions, data 
structures, looping and decision mechanisms, 
procedures, input and output, debugging, and 
Maplets.

Maple 8 Advanced 
Programming Guide1

This guide extends the basic Maple programming 
concepts to more advanced topics, such as modules, 
input and output, numerical programming, 
graphics programming, and compiled code.
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3.3 New User’s Tour
The New User’s Tour is a set of interactive worksheets that you can use to 
learn about Maple. The worksheets present commands that every user should 
know. The tour covers many areas of Maple, such as the worksheet 
environment, numerical calculations, algebraic computations, graphics, 
calculus, differential equations, linear algebra, finance and statistics, 
programming, and online help. The New User’s Tour is easy to follow and a 
single topic only takes 10 to 15 minutes to complete.

To access the New User’s Tour:

• From the Help menu, choose New User’s Tour.

3.4 Example Worksheets
The example worksheets (there are about 80) contain examples from the 
Maple programming language and from ten different areas of mathematics, 
such as algebra, geometry, discrete mathematics, integration, integral 
transforms, differential equations, general symbolics, general numerics, and 
mathematical visualization.

To see the contents of the set of example worksheets:

• At the prompt, enter ��������������� and press ENTER.

3.5 Web Sites
Waterloo Maple’s Web site has, among other things, information on products, 
support, and services. 

To visit Waterloo Maple’s Web site:

• In your Web browser, enter this URL:
���
�������"

���, or

• From the Help menu in your Maple 8 session, select Maple on the Web, 
and Maple Home Page.

The Maple Application Center, includes a forum for sharing solutions, 
demonstrations of Maple PowerTools, and an online tutorial.
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To visit The Maple Application Center Web site:

• In your Web browser, enter this URL:
���
���������
���, or

• From the Help menu in your Maple 8 session, select Maple on the Web, 
and Application Center.

The Student Center, includes course help, Maple tutorials, and Maple 
graphics.

To visit The Student Center Web site:

• In your Web browser, enter this URL:
���
�����-�
����
�
���, or

• From the Help menu in your Maple 8 session, select Maple on the Web, 
and Student Center.
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Command Line Maple, 1–2
commands

case-sensitivity, 9
help, 4, 27
how to enter, 5

in packages, 9
reference pages, 25–26

computations, numeric and symbolic, 1
contents of help, 27
context bar, 3, 19
context-sensitive menus, 11
	
��
�
��
� command, 14
	
���
� command, 17
copying help examples, 26

D
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E
equations, solving, 13
�����command, 16
examples in help, 26
example worksheets, 29
execution group, 4, 19–20
exporting worksheets, 23
Expression palette, 4–6
expressions

entering, 5, 7
referring to, 10

F
finding help topics, 27–28
floating toolbars. See palette
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frames in HTML export, 23
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G
Getting Started Guide, 28
guides, 28

H
headings

sections, 21
worksheets, 19

Help, 26
Help Browser, 25–27
help command, 4, 27
help pages, 4, 25–26
HTML export, 23

I
images in HTML export, 23
indenting worksheet elements, 21
installing Maple, 1
integrals, entering, 5
Introduction page, 2, 27
Introductory Programming Guide, 28

K
keyboard commands, 5

L
LaTeX, 23
launching Maple, 1–2
Learning Guide, 28
licensing Maple, 1
list, 17

M
manuals, 28
Maple Advanced Programming 

Guide, 28
Maple Application Center, 29
Maple Getting Started Guide, 28
Maple help, 25–28
Maple input, 3
Maple Introductory Programming 

Guide, 28
Maple Learning Guide, 10, 28
Maple Notation, 6
Maple output, 4
Maplets, 28
Maple window, 2–3
Maple worksheets. See worksheets
mathematical expressions

entering, 5, 7
referring to, 10

mathematics in text regions, 20–21
MathML, 23
Matrix palette, 4
memory usage, 2
menus, context-sensitive, 11

N
names

assigning, 11
help pages, 26

new execution group, 19–20
New User’s Tour, 2, 29
new worksheet, 9
numbering pages, 22
numerical solutions, 1

O
online help, 4, 25–28
options

page numbers, 22
plot, 17–18

P
packages, 9
page numbers, 22
palette

Expression, 4–6
general information, 5–7
Matrix, 4
Symbol, 4–6
Vector, 4

partial derivatives, 12
plots

adding axes, 11
contour, 14
entering, 11
name assignments, 17
options, 17–18
rotating, 11, 17

��
�� package, 10
positioning page numbers, 22
Programming Guides

Advanced, 28
Introductory, 28

prompt, 4, 19–20

Q
question mark (�) command, 4, 27

R
range brackets, 4
range of plot axes, 11
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reference pages, 25–26
related help pages, 26
right-click menus, 11
rotating plots, 11, 17
RTF, 23

S
saving worksheets, 23
searching help system, 27–28
section

heading, 3
in a worksheet, 4, 21–22
range bracket, 4

semicolon (�) terminator, 6
sets, 13
shortcut buttons. See buttons
shortcut menus, 11
Standard Math Notation, 4–6
starting Maple, 1–2
Student Center, 30
styles for text, 19
symbolic solutions, 1
Symbol palette, 4–6
syntax of commands, 5
system of equations, solving, 13

T
table of contents, help, 27
text entry, 19–21
titles

sections, 21
worksheets, 19

Title text style, 19

toolbar
help page, 26–27
main window, 3, 19

topic search, 27
tutorial. See New User’s Tour

U
URL of Application Center Web site, 30
URL of Web site, 29
user interface elements, 2–4

V
Vector palette, 4

W
Web site address, 29
window features, 2–3
�����command, 9–10, 20
word processing. See text entry
worksheets

adding text, 19
adding title, 19
creating new, 9
example, 29
exporting to HTML, 23
main window, 1, 4
numbering pages, 22
saving, 23
sections, 4, 21–22

X
x and y plot axes, 11
XML, 23
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